<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>WATCH: Center Township General Meeting 7-1-2019 - BeaverCountian.com</title>
    <meta charset="UTF-8"/>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://beavercountian.com/xmlrpc.php"/>
    <meta property="og:image" content="https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg"/><link rel="icon" type="image/png" href="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2017/02/favicon.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2017/02/bookmark-76.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2017/02/bookmark-120.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2017/02/bookmark-152.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2017/02/bookmark-114.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2017/02/bookmark-144.png"/>
<!-- This site is optimized with the Yoast SEO plugin v11.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="WATCH: Center Township General Meeting 7-1-2019 - BeaverCountian.com"/>
<meta property="og:description" content="Engineer Report &#8211; 2018 Roads. A reduction in contract price was motioned in the amount of $39,375.45 &#8211; 2019 Roads. Issues were brought up about who was supposed to pay for part of a contract. PA DEP &#8211; Drainage issues with Ceder Ridge pond were discussed. A new plan is needed &hellip;"/>
<meta property="og:url" content="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019"/>
<meta property="og:site_name" content="BeaverCountian.com"/>
<meta property="article:publisher" content="https://www.facebook.com/BeaverCountian/"/>
<meta property="article:tag" content="Center Township"/>
<meta property="article:section" content="Public Meetings"/>
<meta property="article:published_time" content="2019-07-02T22:54:52+00:00"/>
<meta property="article:modified_time" content="2019-07-02T22:56:46+00:00"/>
<meta property="og:updated_time" content="2019-07-02T22:56:46+00:00"/>
<meta property="fb:app_id" content="253067775027"/>
<meta property="og:image" content="https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg"/>
<meta property="og:image:secure_url" content="https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg"/>
<meta property="og:image:width" content="1280"/>
<meta property="og:image:height" content="720"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="Engineer Report &#8211; 2018 Roads. A reduction in contract price was motioned in the amount of $39,375.45 &#8211; 2019 Roads. Issues were brought up about who was supposed to pay for part of a contract. PA DEP &#8211; Drainage issues with Ceder Ridge pond were discussed. A new plan is needed [&hellip;]"/>
<meta name="twitter:title" content="WATCH: Center Township General Meeting 7-1-2019 - BeaverCountian.com"/>
<meta name="twitter:site" content="@beavercountian"/>
<meta name="twitter:image" content="https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg"/>
<meta name="twitter:creator" content="@beavercountian"/>
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://beavercountian.com/#organization","name":"BeaverCountian.com","url":"https://beavercountian.com/","sameAs":["https://www.facebook.com/BeaverCountian/","http://www.youtube.com/c/BeavercountianCom","https://twitter.com/beavercountian"],"logo":{"@type":"ImageObject","@id":"https://beavercountian.com/#logo","url":"https://beavercountian.com/wp-content/uploads/2018/06/beaver-countian-logo.jpg","width":800,"height":600,"caption":"BeaverCountian.com"},"image":{"@id":"https://beavercountian.com/#logo"}},{"@type":"WebSite","@id":"https://beavercountian.com/#website","url":"https://beavercountian.com/","name":"BeaverCountian.com","publisher":{"@id":"https://beavercountian.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://beavercountian.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#primaryimage","url":"https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg","width":1280,"height":720},{"@type":"WebPage","@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#webpage","url":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019","inLanguage":"en-US","name":"WATCH: Center Township General Meeting 7-1-2019 - BeaverCountian.com","isPartOf":{"@id":"https://beavercountian.com/#website"},"primaryImageOfPage":{"@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#primaryimage"},"datePublished":"2019-07-02T22:54:52+00:00","dateModified":"2019-07-02T22:56:46+00:00"},{"@type":"NewsArticle","@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#article","isPartOf":{"@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#webpage"},"author":{"@id":"https://beavercountian.com/schema/person/matthew-lacomb/#author"},"headline":"WATCH: Center Township General Meeting 7-1-2019","datePublished":"2019-07-02T22:54:52+00:00","dateModified":"2019-07-02T22:56:46+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#webpage"},"publisher":{"@id":"https://beavercountian.com/#organization"},"image":{"@id":"https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#primaryimage"},"keywords":"Center Township","articleSection":"Public Meetings","copyrightYear":"2019","copyrightHolder":{"@id":"https://beavercountian.com#organization"}},{"@type":["Person"],"@id":"https://beavercountian.com/content/author/mattlacomb#author","name":"Matthew LaComb","image":{"@type":"ImageObject","@id":"https://beavercountian.com/#authorlogo","url":"https://secure.gravatar.com/avatar/b703e41681186a71d095141626f4cfc0?s=96&d=wavatar&r=pg","caption":"Matthew LaComb"},"description":"Matt is a BeaverCountian.com multimedia contributor. When he doesn't have a camera in his hands, he's often conducting research projects for the site.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//d30s8nmy80irhh.cloudfront.net'/>
<link rel='dns-prefetch' href='//cdn.onesignal.com'/>
<link rel="alternate" type="application/rss+xml" title="BeaverCountian.com &raquo; Feed" href="https://beavercountian.com/feed"/>
<link rel="alternate" type="application/rss+xml" title="BeaverCountian.com &raquo; Comments Feed" href="https://beavercountian.com/comments/feed"/>
<link rel="alternate" type="application/rss+xml" title="BeaverCountian.com &raquo; WATCH: Center Township General Meeting 7-1-2019 Comments Feed" href="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019/feed"/>
<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><!--noptimize--><script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script><!--/noptimize--><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
	<link rel='stylesheet' id='pmpro_frontend-css' href='https://beavercountian.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=2.0.7' type='text/css' media='screen'/>
<link rel='stylesheet' id='pmpro_print-css' href='https://beavercountian.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=2.0.7' type='text/css' media='print'/>
<link rel='stylesheet' id='wp-block-library-css' href='https://beavercountian.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='wc-block-style-css' href='https://beavercountian.com/wp-content/plugins/woocommerce/assets/css/blocks/style.css?ver=3.6.5' type='text/css' media='all'/>
<link rel='stylesheet' id='amazonpolly-css' href='https://beavercountian.com/wp-content/plugins/amazon-polly/public/css/amazonpolly-public.css?ver=1.0.0' type='text/css' media='all'/>
<link rel='stylesheet' id='bbp-default-css' href='https://beavercountian.com/wp-content/plugins/bbpress/templates/default/css/bbpress.css?ver=2.5.14-6684' type='text/css' media='screen'/>
<link rel='stylesheet' id='wpw-fp-public-style-css' href='https://beavercountian.com/wp-content/plugins/follow-my-blog-post/includes/css/wpw-fp-public.css?ver=1.9.12' type='text/css' media='all'/>
<link rel='stylesheet' id='pmpro-add-paypal-express-styles-css' href='https://beavercountian.com/wp-content/plugins/pmpro-add-paypal-express/css/pmpro-add-paypal-express.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='pmpro-woocommerce-css' href='https://beavercountian.com/wp-content/plugins/pmpro-woocommerce/css/style.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='theme-my-login-css' href='https://beavercountian.com/wp-content/plugins/theme-my-login/assets/styles/theme-my-login.min.css?ver=7.0.14' type='text/css' media='all'/>
<link rel='stylesheet' id='vc-weather-css' href='https://beavercountian.com/wp-content/plugins/vc-weather/css/vc-weather.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='vc-meteocons-css' href='https://beavercountian.com/wp-content/plugins/vc-weather/css/meteocons.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='woocommerce-layout-css' href='https://beavercountian.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=3.6.5' type='text/css' media='all'/>
<link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://beavercountian.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=3.6.5' type='text/css' media='only screen and (max-width: 768px)'/>
<link rel='stylesheet' id='woocommerce-general-css' href='https://beavercountian.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=3.6.5' type='text/css' media='all'/>
<style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required{visibility:visible}</style>
<link rel='stylesheet' id='wpdiscuz-font-awesome-css' href='https://beavercountian.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.0.6/css/fontawesome-all.min.css?ver=5.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='wpdiscuz-frontend-css-css' href='https://beavercountian.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=5.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='wmu-colorbox-css-css' href='https://beavercountian.com/wp-content/plugins/wpdiscuz-media-uploader/assets/third-party/colorbox/colorbox.min.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='wmu-frontend-css-css' href='https://beavercountian.com/wp-content/plugins/wpdiscuz-media-uploader/assets/css/wmu-frontend.css?ver=1.3.9' type='text/css' media='all'/>
<link rel='stylesheet' id='easy-social-share-buttons-css' href='https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/assets/css/easy-social-share-buttons.min.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='easy-social-share-buttons-display-methods-css' href='https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/assets/css/essb-display-methods.min.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='essb-social-followers-counter-css' href='https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/social-followers-counter/assets/css/essb-followers-counter.min.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='wc-memberships-frontend-css' href='https://beavercountian.com/wp-content/plugins/woocommerce-memberships/assets/css/frontend/wc-memberships-frontend.min.css?ver=1.13.1' type='text/css' media='all'/>
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://beavercountian.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=61179afdbbd6a8d8c8a7f82ae3fcd87d' type='text/css' media='all'/>
<link rel='stylesheet' id='evo_wv_styles-css' href='https://beavercountian.com/wp-content/plugins/eventon-weekly-view/assets/wv_styles.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='evcal_google_fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.2.2' type='text/css' media='screen'/>
<link rel='stylesheet' id='evcal_cal_default-css' href='https://beavercountian.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.6.17' type='text/css' media='all'/>
<link rel='stylesheet' id='evo_font_icons-css' href='https://beavercountian.com/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.6.17' type='text/css' media='all'/>
<link rel='stylesheet' id='eventon_dynamic_styles-css' href='https://beavercountian.com/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='essb_theme_standard-css' href='https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/top-posts-widget/css/essb-theme-standard.min.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='essb-font-css' href='https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/top-posts-widget/css/essb-posts-font.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='eventon_em_styles-css' href='https://beavercountian.com/wp-content/plugins/eventon-events-map/assets/evmap_style.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='evo_dv_styles-css' href='https://beavercountian.com/wp-content/plugins/eventon-daily-view/assets/dv_styles.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='evo_el_styles-css' href='https://beavercountian.com/wp-content/plugins/eventon-event-lists/assets/el_styles.css?ver=5.2.2' type='text/css' media='all'/>
<link rel='stylesheet' id='evosl_styles-css' href='https://beavercountian.com/wp-content/plugins/eventon-event-slider/assets/evosl_styles.css?ver=1.0.6' type='text/css' media='all'/>
<link rel='stylesheet' id='evo_fc_styles-css' href='https://beavercountian.com/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=1.1.6' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-css' href='https://beavercountian.com/wp-content/themes/Newspaper/style.css?ver=9.7.3' type='text/css' media='all'/>
<style id='td-theme-inline-css' type='text/css'>@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style>
<link rel='stylesheet' id='td-theme-bbpress-css' href='https://beavercountian.com/wp-content/themes/Newspaper/style-bbpress.css?ver=9.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-woo-css' href='https://beavercountian.com/wp-content/themes/Newspaper/style-woocommerce.css?ver=9.7.3' type='text/css' media='all'/>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://beavercountian.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=61179afdbbd6a8d8c8a7f82ae3fcd87d' type='text/css' media='all'/>
<script type='text/javascript' src='https://beavercountian.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/amazon-polly/public/js/amazonpolly-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=5.3.2'></script>
<script type='text/javascript'>//<![CDATA[
var wpdiscuzAjaxObj={"url":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/beavercountian.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"Show Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You&#039;ve already voted for this comment","wc_voting_error":"Voting Error","wc_held_for_moderate":"Comment awaiting moderation","wc_comment_edit_not_possible":"Sorry, this comment no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You&#039;ve not made any changes","wc_new_comment_button_text":"new comment","wc_new_comments_button_text":"new comments","wc_new_reply_button_text":"new reply on your comment","wc_new_replies_button_text":"new replies on your comments","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn&#039;t send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can&#039;t follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":false,"commentListLoadType":"2","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#fefefe","wc_reply_bg_color":"#EEEEEE","wpdiscuzCommentsOrder":"asc","wpdiscuzCommentOrderBy":"comment_date_gmt","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"3","wordpressIsPaginate":"","commentTextMaxLength":null,"storeCommenterData":100000,"isCaptchaInSession":false,"isGoodbyeCaptchaActive":false,"socialLoginAgreementCheckbox":0,"enableFbLogin":0,"enableFbShare":0,"facebookAppID":"","facebookUseOAuth2":0,"enableGoogleLogin":0,"googleAppID":"","cookiehash":"d32b47f4f334c4530ed69ebffb813100","isLoadOnlyParentComments":0,"ahk":"ih&=gd=2(h)6n9lq8na%!fylq8)9^%2h","enableDropAnimation":0,"isNativeAjaxEnabled":0,"cookieCommentsSorting":"wpdiscuz_comments_sorting","enableLastVisitCookie":0,"version":"5.3.2","wc_post_id":6558888,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","isCookiesEnabled":true,"wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","is_email_field_required":1,"url":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php","uploader":1,"wmuVersion":"1.3.9","iconVideoAudio":"https:\/\/beavercountian.com\/wp-content\/plugins\/wpdiscuz-media-uploader\/assets\/img\/file-icons\/video-audio-type.png","iconFile":"https:\/\/beavercountian.com\/wp-content\/plugins\/wpdiscuz-media-uploader\/assets\/img\/file-icons\/file-type.png","wmuIsLightbox":1,"confirmDelete":"Are you sure you want to delete this attachment?","msgNotAllowedFiles":"Not allowed file type: ","msgMaxFileCount":"Maximum number of uploaded files is  3","msgMaxFileSize":"Maximum upload file size is  30MB","msgPostMaxSize":"Maximum post size is  40M","wmuLazyLoadImages":1}};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/wpdiscuz-media-uploader/assets/third-party/colorbox/jquery.colorbox.min.js?ver=1.3.9'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/wpdiscuz-media-uploader/assets/third-party/exif/exif.min.js?ver=1.3.9'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/wpdiscuz-media-uploader/assets/js/wmu-multiple.min.js?ver=1.3.9'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.14'></script>
<script type='text/javascript'>//<![CDATA[
var advanced_ads_responsive={"reload_on_resize":"0"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.8.7'></script>
<script type='text/javascript'>//<![CDATA[
var advanced_ads_pro_visitor_conditions={"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.4.1'></script>
<script type='text/javascript'>//<![CDATA[
var advanced_ads_pro_ajax_object={"ajax_url":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]}};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.4.1'></script>
<link rel='https://api.w.org/' href='https://beavercountian.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://beavercountian.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://beavercountian.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 5.2.2"/>
<meta name="generator" content="WooCommerce 3.6.5"/>
<link rel='shortlink' href='https://beavercountian.com/?p=6558888'/>
            <style>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</style>
            
<script type="text/javascript">var essb_settings={"ajax_url":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php","essb3_nonce":"5910d58854","essb3_plugin_url":"https:\/\/beavercountian.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/beavercountian.com\/","essb3_postfloat_stay":false,"post_id":6558888};</script><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    			<script>window.tdwGlobal={"adminUrl":"https:\/\/beavercountian.com\/wp-admin\/","wpRestNonce":"1bd3b737e3","wpRestUrl":"https:\/\/beavercountian.com\/wp-json\/","permalinkStructure":"\/content\/%category%\/%postname%"};</script>
			<meta name="theme-color" content="#ffcc00"><meta name="msapplication-navbutton-color" content="#ffcc00"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="black-translucent">	<noscript><style>.woocommerce-product-gallery{opacity:1!important}</style></noscript>
	      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest" href="https://beavercountian.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=134448125047"/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("https://d30s8nmy80irhh.cloudfront.net/");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='160c5b7a-5cbc-46a4-8ae9-8efda2e4efe0';oneSignal_options['autoRegister']=true;oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="The Beaver Countian";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['welcomeNotification']['url']="https://BeaverCountian.com";oneSignal_options['path']="https://beavercountian.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";oneSignal_options['safari_web_id']="web.onesignal.auto.47e61a84-7486-476e-83ad-85400aafc6ca";oneSignal_options['persistNotification']=true;oneSignal_options['promptOptions']={};OneSignal.init(window._oneSignalInitOptions);});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script>


<!-- JS generated by theme -->

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var tdc_is_installed="yes";var td_ajax_url="https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.7.3";var td_get_template_directory_uri="https:\/\/beavercountian.com\/wp-content\/plugins\/td-composer\/legacy\/common";var tds_snap_menu="";var tds_logo_on_sticky="";var tds_header_style="11";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#ffcc00";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdBlockNonce="9425060e70";var tdsDateFormat="l, F j, Y";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://beavercountian.com/wp-content/cache/busting/google-tracking/ga-4d88a66690f3506e6a2112b1c4dce0b4.js','ga');ga('create','UA-9631849-6','auto');ga('send','pageview');</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://beavercountian.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://beavercountian.com/content/category/public-meetings",
                    "name": "Public Meetings"
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>li>a:hover,.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,.tdm-social-item i{color:#fc0}.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>li>a:hover,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.sfHover>a,.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#fc0}.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-item>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>li>a:hover,.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a,.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#fc0}.tdm-btn-style1{background-color:#fc0}.tdm-btn-style2:before{border-color:#fc0}.tdm-btn-style2{color:#fc0}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #fc0;-moz-box-shadow:0 2px 16px #fc0;box-shadow:0 2px 16px #fc0}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #fc0;-moz-box-shadow:0 4px 26px #fc0;box-shadow:0 4px 26px #fc0}.tdm-header-style-1.td-header-wrap .td-header-top-menu-full,.tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-2.td-header-wrap .td-header-top-menu-full,.tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-3.td-header-wrap .td-header-top-menu-full,.tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{background-color:#000}.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>li>a:hover,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a{color:#000}.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-item>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>li>a:hover,.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a{border-color:#000}.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu>li>a:hover,.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu>.sfHover>a{background-color:#000}</style>

	<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-6558888 single-format-video pmpro-body-level-required pmpro-body-level-5 pmpro-body-level-6 pmpro-body-level-2 pmpro-body-level-3 pmpro-body-level-1 pmpro-body-level-4 pmpro-body-has-access woocommerce-no-js watch-center-township-general-meeting-7-1-2019 global-block-template-1 single_template_11 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://facebook.com/BeaverCountian" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/beavercountian" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-header-menu-container"><ul id="menu-header-menu" class="td-mobile-main-menu"><li id="menu-item-6032938" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-6032938"><a href="/"><i class="fa fa-home td-only-icon"></i></a></li>
<li id="menu-item-6434807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6434807"><a href="https://beavercountian.com/login"><i class="fa fa-lock"></i>Log In</a></li>
<li id="menu-item-6436750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6436750"><a href="https://beavercountian.com/membership-account"><i class="fa fa-shopping-cart"></i>Subscribe!</a></li>
<li id="menu-item-6542532" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6542532"><a href="https://beavercountian.com/about-the-beaver-countian"><i class="fa fa-address-card"></i>About</a></li>
<li id="menu-item-6211485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6211485"><a href="/contact"><i class="fa fa-envelope"></i>Contact</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://beavercountian.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off"/>
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 11
-->

<div class="td-header-wrap td-header-style-11 ">
    
	<div class="td-header-top-menu-full td-container-wrap ">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-3">
        
<div class="td-header-sp-top-menu">


	<!-- td weather source: cache -->		<div class="td-weather-top-widget" id="td_top_weather_uid">
			<i class="td-icons scattered-clouds-d"></i>
			<div class="td-weather-now" data-block-uid="td_top_weather_uid">
				<span class="td-big-degrees">88.2</span>
				<span class="td-weather-unit">F</span>
			</div>
			<div class="td-weather-header">
				<div class="td-weather-city">Beaver</div>
			</div>
		</div>
		        <div class="td_data_time">
            <div style="visibility:hidden;">

                Tuesday, July 2, 2019
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->
		</div>
	</div>

    <div class="td-header-menu-wrap-full td-container-wrap td_stretch_container">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
                <a class="td-main-logo" href="https://beavercountian.com/">
            <img class="td-retina-data" data-retina="https://beavercountian.com/wp-content/uploads/2019/02/beavercountian-logo-transparent-tight.png" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/02/beavercountian-logo-transparent-tight.png" alt="Beaver Countian" title="Beaver County News"/>
        </a>
        </div>
    <div class="menu-header-menu-container"><ul id="menu-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-6032938"><a href="/"><i class="fa fa-home td-only-icon"></i></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6434807"><a href="https://beavercountian.com/login"><i class="fa fa-lock"></i>Log In</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6436750"><a href="https://beavercountian.com/membership-account"><i class="fa fa-shopping-cart"></i>Subscribe!</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6542532"><a href="https://beavercountian.com/about-the-beaver-countian"><i class="fa fa-address-card"></i>About</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6211485"><a href="/contact"><i class="fa fa-envelope"></i>Contact</a></li>
</ul></div></div>

<div class="td-header-menu-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://facebook.com/BeaverCountian" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/beavercountian" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://beavercountian.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search"/>
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<a class="td-main-logo" href="https://beavercountian.com/">
			<img class="td-retina-data" data-retina="https://beavercountian.com/wp-content/uploads/2019/02/beavercountian-logo-transparent-tight.png" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/02/beavercountian-logo-transparent-tight.png" alt="Beaver Countian" title="Beaver County News" width="1006"/>
			<span class="td-visual-hidden">BeaverCountian.com</span>
		</a>
	        </div>
    </div>

    
</div>
            </div>

            
<article id="post-6558888" class="td-post-template-11 post-6558888 post type-post status-publish format-video has-post-thumbnail hentry category-public-meetings tag-center-township post_format-post-format-video pmpro-level-required pmpro-level-5 pmpro-level-6 pmpro-level-2 pmpro-level-3 pmpro-level-1 pmpro-level-4 pmpro-has-access td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-video-template-bg">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span12 td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://beavercountian.com/">Home</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Public Meetings</span></div></div>

                <div class="td-pb-span4 td-post-header">

                    
                    <header class="td-post-title">
                        <h1 class="entry-title">WATCH: Center Township General Meeting 7-1-2019</h1>

                        

                        <div class="td-module-meta-info">
                            <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://beavercountian.com/content/author/mattlacomb">Matthew LaComb</a><div class="td-author-line"> - </div> </div>                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-02T18:54:52+00:00">Jul 2, 2019</time></span>                                                        <div class="td-post-comments"><a href="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019#respond"><i class="td-icon-comments"></i>0</a></div>                        </div>
                    </header>


                    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-post_style_11 td_uid_1_5d1befc592d0f_rand td_block_template_1 ">

<style>.td_uid_1_5d1befc592d0f_rand.td-a-rec-img{text-align:left}.td_uid_1_5d1befc592d0f_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6853092687915805" data-ad-slot="1724239134"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6853092687915805" data-ad-slot="1724239134"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-6853092687915805" data-ad-slot="1724239134"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6853092687915805" data-ad-slot="1724239134"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script>
</div>

 <!-- end A --> 


                </div>

                <div class="td-pb-span8 td-post-featured-video">
                    
                <div class="wpb_video_wrapper">
                    <iframe id="td_youtube_player" width="600" height="560" src="https://www.youtube.com/embed/DCI_jDsCsQs?enablejsapi=1&feature=oembed&wmode=opaque&vq=hd720" frameborder="0" allowfullscreen=""></iframe>
                    <script type="text/javascript">var tag=document.createElement("script");tag.src="https://www.youtube.com/iframe_api";var firstScriptTag=document.getElementsByTagName("script")[0];firstScriptTag.parentNode.insertBefore(tag,firstScriptTag);var player;function onYouTubeIframeAPIReady(){player=new YT.Player("td_youtube_player",{height:"720",width:"960",events:{"onReady":onPlayerReady}});}
function onPlayerReady(event){player.setPlaybackQuality("hd720");}</script>

                </div>

                
                    
                </div>
            </div>
        </div>
    </div>
    <div class="td-video-template-bg-small">
        <div class="td-container">
                  <div class="td_block_wrap td_block_related_posts td-related-full-width td_uid_2_5d1befc593089_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_2_5d1befc593089"><script>var block_td_uid_2_5d1befc593089=new tdBlock();block_td_uid_2_5d1befc593089.id="td_uid_2_5d1befc593089";block_td_uid_2_5d1befc593089.atts='{"limit":5,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td-related-full-width td_uid_2_5d1befc593089_rand","td_column_number":5,"live_filter_cur_post_id":6558888,"live_filter_cur_post_author":"6478","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_5d1befc593089_rand","tdc_css_class_style":"td_uid_2_5d1befc593089_rand_style"}';block_td_uid_2_5d1befc593089.td_column_number="5";block_td_uid_2_5d1befc593089.block_type="td_block_related_posts";block_td_uid_2_5d1befc593089.post_count="5";block_td_uid_2_5d1befc593089.found_posts="73";block_td_uid_2_5d1befc593089.header_color="";block_td_uid_2_5d1befc593089.ajax_pagination_infinite_stop="";block_td_uid_2_5d1befc593089.max_num_pages="15";tdBlocksArray.push(block_td_uid_2_5d1befc593089);</script><h4 class="td-related-title td-block-title"><a id="td_uid_3_5d1befc593b97" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_2_5d1befc593089" href="#">RELATED ARTICLES</a><a id="td_uid_4_5d1befc593c43" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_2_5d1befc593089" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_2_5d1befc593089 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://beavercountian.com/content/public-meetings/watch-beaver-county-board-of-commissioners-work-session-6-26-2019" rel="bookmark" class="td-image-wrap" title="WATCH: Beaver County Board of Commissioners Work Session 6-26-2019"><img width="218" height="150" class="entry-thumb" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-9-218x150.jpg" srcset="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-9-218x150.jpg 218w, https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-9-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="WATCH: Beaver County Board of Commissioners Work Session 6-26-2019"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://beavercountian.com/content/public-meetings/watch-beaver-county-board-of-commissioners-work-session-6-26-2019" rel="bookmark" title="WATCH: Beaver County Board of Commissioners Work Session 6-26-2019">WATCH: Beaver County Board of Commissioners Work Session 6-26-2019</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://beavercountian.com/content/public-meetings/watch-economy-borough-general-meeting-6-25-2019" rel="bookmark" class="td-image-wrap" title="WATCH: Economy Borough General Meeting 6-25-2019"><img width="218" height="150" class="entry-thumb" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-8-218x150.jpg" srcset="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-8-218x150.jpg 218w, https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-8-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="WATCH: Economy Borough General Meeting 6-25-2019"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://beavercountian.com/content/public-meetings/watch-economy-borough-general-meeting-6-25-2019" rel="bookmark" title="WATCH: Economy Borough General Meeting 6-25-2019">WATCH: Economy Borough General Meeting 6-25-2019</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://beavercountian.com/content/public-meetings/watch-hopewell-twp-board-of-commissioners-meeting-6-25-2019" rel="bookmark" class="td-image-wrap" title="WATCH: Hopewell Twp Board of Commissioners Meeting 6-24-2019"><img width="218" height="150" class="entry-thumb" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/hopewell-twp-6-25-2019-218x150.jpg" srcset="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/hopewell-twp-6-25-2019-218x150.jpg 218w, https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/hopewell-twp-6-25-2019-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="WATCH: Hopewell Twp Board of Commissioners Meeting 6-24-2019"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://beavercountian.com/content/public-meetings/watch-hopewell-twp-board-of-commissioners-meeting-6-25-2019" rel="bookmark" title="WATCH: Hopewell Twp Board of Commissioners Meeting 6-24-2019">WATCH: Hopewell Twp Board of Commissioners Meeting 6-24-2019</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://beavercountian.com/content/public-meetings/west-mayfield-board-of-commissioners-meeting-6-13-2019" rel="bookmark" class="td-image-wrap" title="WATCH: West Mayfield Board of Commissioners Meeting 6-13-2019"><img width="218" height="150" class="entry-thumb" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-7-218x150.jpg" srcset="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-7-218x150.jpg 218w, https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-7-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="WATCH: West Mayfield Board of Commissioners Meeting 6-13-2019"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://beavercountian.com/content/public-meetings/west-mayfield-board-of-commissioners-meeting-6-13-2019" rel="bookmark" title="WATCH: West Mayfield Board of Commissioners Meeting 6-13-2019">WATCH: West Mayfield Board of Commissioners Meeting 6-13-2019</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://beavercountian.com/content/public-meetings/daugherty-township-board-of-supervisors-meeting-6-12-2019" rel="bookmark" class="td-image-wrap" title="WATCH: Daugherty Township Board of Supervisors Meeting 6-12-2019"><img width="218" height="150" class="entry-thumb" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-6-218x150.jpg" srcset="https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-6-218x150.jpg 218w, https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/06/maxresdefault-6-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="WATCH: Daugherty Township Board of Supervisors Meeting 6-12-2019"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://d30s8nmy80irhh.cloudfront.net/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://beavercountian.com/content/public-meetings/daugherty-township-board-of-supervisors-meeting-6-12-2019" rel="bookmark" title="WATCH: Daugherty Township Board of Supervisors Meeting 6-12-2019">WATCH: Daugherty Township Board of Supervisors Meeting 6-12-2019</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5d1befc593089" data-td_block_id="td_uid_2_5d1befc593089"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5d1befc593089" data-td_block_id="td_uid_2_5d1befc593089"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <div class="td-post-content">

        
	<div class="wpw-fp-follow-post-wrapper wpw-fp-follow-btn-wrapper">
			</div><!-- wpw-fp-follow-post-wrapper --><div class="essb_links essb_counter_modern_left essb_displayed_postfloat essb_share essb_template_default4-retina essb_template_color-circles-retina essb_882123919 essb_size_l essb_links_right essb_mobile_hidden print-no" id="essb_displayed_postfloat_882123919" data-essb-postid="6558888" data-essb-position="postfloat" data-essb-button-style="icon_hover" data-essb-template="default4-retina essb_template_color-circles-retina" data-essb-counter-pos="left" data-essb-url="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019" data-essb-twitter-url="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019" data-essb-instance="882123919">
<ul class="essb_links_list essb_hide_name">
<li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&#038;t=WATCH%3A+Center+Township+General+Meeting+7-1-2019" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&#038;t=WATCH%3A+Center+Township+General+Meeting+7-1-2019&#39;,&#39;facebook&#39;,&#39;882123919&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li>
<li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=WATCH%3A+Center+Township+General+Meeting+7-1-2019&amp;url=https://beavercountian.com/?p=6558888&amp;counturl=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&#39;,&#39;twitter&#39;,&#39;882123919&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li>
<li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=WATCH%3A+Center+Township+General+Meeting+7-1-2019&amp;url=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=WATCH%3A+Center+Township+General+Meeting+7-1-2019&amp;url=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&#39;,&#39;linkedin&#39;,&#39;882123919&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a></li>
<li class="essb_item essb_link_comments nolightbox"> <a href="#comments" title="" onclick="essb.tracking_only('', 'comments', '882123919', true);" target="_self" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_comments"></span><span class="essb_network_name">Comments</span></a></li>
</ul>
</div>
<p><strong>Engineer Report</strong></p>
<p>&#8211; 2018 Roads. A reduction in contract price was motioned in the amount of $39,375.45</p>
<p>&#8211; 2019 Roads. Issues were brought up about who was supposed to pay for part of a contract.</p>
<p><strong>PA DEP</strong></p>
<p>&#8211; Drainage issues with Ceder Ridge pond were discussed. A new plan is needed to fix this issue, which requires the construction of an access road. Discussion took place about where to construct it due to the pond&#8217;s position behind residents&#8217; properties. One of the property owners contacted the Conservation District, who did a test on mosquitoes that tested positive for West Nile Virus.  </p>
<p>&#8211; Discussion about a dedicated turn lane next to the Beaver Valley Mall. The developer would need township support and approval to construct this plan.  </p>
<p><strong>Solicitor Report [17:10]</strong></p>
<p>&#8211; An executive session was requested regarding litigation with no need to reconvene.</p>
<p><strong>Old Business [19:30]</strong></p>
<p>&#8211; Currently getting bids on trash receptacles for 2020.</p>
<p><strong>BOC Report</strong></p>
<p>– None</p>
<p><strong>New Business</strong> </p>
<p>– None</p>
<p>*An approval for final payment of the 2018 road program was made in the amount of $100,749.25.</p>
<div class="essb_links essb_counters essb_displayed_bottom essb_share essb_template_fancy-bold-retina essb_1290351845 essb_width_columns_2 essb_size_l print-no" id="essb_displayed_bottom_1290351845" data-essb-postid="6558888" data-essb-position="bottom" data-essb-button-style="button" data-essb-template="fancy-bold-retina" data-essb-counter-pos="hidden" data-essb-url="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019" data-essb-twitter-url="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019" data-essb-instance="1290351845"><ul class="essb_links_list"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&t=WATCH%3A+Center+Township+General+Meeting+7-1-2019" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&t=WATCH%3A+Center+Township+General+Meeting+7-1-2019&#39;,&#39;facebook&#39;,&#39;1290351845&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Share</span></a><span class="essb_counter_hidden" data-cnt="2" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=WATCH%3A+Center+Township+General+Meeting+7-1-2019&amp;url=https://beavercountian.com/?p=6558888&amp;counturl=https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019&#39;,&#39;twitter&#39;,&#39;1290351845&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Tweet</span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_totalcount_item essb_totalcount_item_before" style="display: none !important;" data-essb-hide-till="100" data-counter-pos="hidden"><span class="essb_totalcount essb_t_before" title=""><span class="essb_t_nb">2</span> shares</span></li></ul></div><div class="essb_break_scroll"></div><div class="td-a-rec td-a-rec-id-content_bottom  td_uid_5_5d1befc596787_rand td_block_template_1">
<style>.td_uid_5_5d1befc596787_rand.td-a-rec-img{text-align:left}.td_uid_5_5d1befc596787_rand.td-a-rec-img img{margin:0 auto 0 0}</style><div style="clear: both; width: 100%; margin: 20px 0 0 0">
<div style="display: inline-block;"><div id="beave-df8c8bb590b8f9fc74902031e61f522d"></div></div>
<div style="display: inline-block;"><div id="beave-e3560e329dc307992a73f7bf5ebd3740"></div></div>
</div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                                </div>

                        <div class="author-box-wrap"><a href="https://beavercountian.com/content/author/mattlacomb"><img alt='Matthew LaComb' src='https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/02/Matthew-LaComb_avatar-96x96.jpg' class='avatar avatar-96 photo' height='96' width='96'/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://beavercountian.com/content/author/mattlacomb">Matthew LaComb</a></span></div><div class="td-author-description">Matt is a BeaverCountian.com multimedia contributor. When he doesn't have a camera in his hands, he's often conducting research projects for the site.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Matthew LaComb"></span><meta itemprop="datePublished" content="2019-07-02T18:54:52+00:00"><meta itemprop="dateModified" content="2019-07-02T18:56:46-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://beavercountian.com/content/public-meetings/watch-center-township-general-meeting-7-1-2019"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://beavercountian.com/wp-content/uploads/2019/02/beavercountian-logo-transparent-tight.png"></span><meta itemprop="name" content="BeaverCountian.com"></span><meta itemprop="headline " content="WATCH: Center Township General Meeting 7-1-2019"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="720"></span>    </footer>

    <div class="wpdiscuz_top_clearing"></div>
    <div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>            <h3 id="wc-comment-header">
                                Reader Comments            </h3>
                    <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
            <div class="wpdiscuz-form-top-bar">
                <div class="wpdiscuz-ftb-left">
                                                            <div id="wc_show_hide_loggedin_username">
                                            </div>
                </div>
                                <div class="wpd-clear"></div>
            </div>


                        <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper" id='wc-main-form-wrapper-0_0'>
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post" enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img alt='avatar' src='https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/07/maxresdefault.jpg' srcset='https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg 2x' class='avatar avatar-40 photo avatar-default' height='40' width='40'/>                                    </div>
                                
                                <textarea id="wc-textarea-0_0" placeholder="Click here to post your comments to this article!..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                                                    <div class="wpdiscuz-textarea-foot">
                                        <label class='wmu-add wmu-multiple'><span class='wpdiscuz-button wmu-icon-image'>&nbsp;</span><input type='hidden' class='wmu-type wmu-hide' value='image'></label><label class='wmu-add wmu-multiple'><span class='wpdiscuz-button wmu-icon-video'>&nbsp;</span><input type='hidden' class='wmu-type wmu-hide' value='video'></label><label class='wmu-add wmu-multiple'><span class='wpdiscuz-button wmu-icon-file'>&nbsp;</span><input type='hidden' class='wmu-type wmu-hide' value='file'></label>                                        <div class="wpdiscuz-button-actions"><div class="wmu-action-wrap"><div class='wmu-tabs wmu-multi-file wmu-image-tab wmu-hide'><div class='wmu-top-title'>Photo and Image Files</div><label class='wmu-add wmu-add-0 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-image-0' class='wmu-image wmu_reset wmu-hide' type='file' name='wmu_image[]'/></label><div class='wmu-preview wmu-preview-image wmu-preview-image-0 wmu-hide'><div class='wmu-preview-remove'><canvas style='max-height:45px;' id='image-0_0-canvas-0'></canvas><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-1 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-image-1' class='wmu-image wmu_reset wmu-hide' type='file' name='wmu_image[]'/></label><div class='wmu-preview wmu-preview-image wmu-preview-image-1 wmu-hide'><div class='wmu-preview-remove'><canvas style='max-height:45px;' id='image-0_0-canvas-1'></canvas><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-2 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-image-2' class='wmu-image wmu_reset wmu-hide' type='file' name='wmu_image[]'/></label><div class='wmu-preview wmu-preview-image wmu-preview-image-2 wmu-hide'><div class='wmu-preview-remove'><canvas style='max-height:45px;' id='image-0_0-canvas-2'></canvas><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div></div><div class='wmu-tabs wmu-multi-file wmu-video-tab wmu-hide'><div class='wmu-top-title'>Audio and Video Files</div><label class='wmu-add wmu-add-0 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-video-0' class='wmu-video wmu_reset wmu-hide' type='file' name='wmu_video[]'/></label><div class='wmu-preview wmu-preview-video wmu-preview-video-0 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-1 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-video-1' class='wmu-video wmu_reset wmu-hide' type='file' name='wmu_video[]'/></label><div class='wmu-preview wmu-preview-video wmu-preview-video-1 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-2 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-video-2' class='wmu-video wmu_reset wmu-hide' type='file' name='wmu_video[]'/></label><div class='wmu-preview wmu-preview-video wmu-preview-video-2 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div></div><div class='wmu-tabs wmu-multi-file wmu-file-tab wmu-hide'><div class='wmu-top-title'>Other File Types</div><label class='wmu-add wmu-add-0 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-file-0' class='wmu-file wmu_reset wmu-hide' type='file' name='wmu_file[]'/></label><div class='wmu-preview wmu-preview-file wmu-preview-file-0 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-1 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-file-1' class='wmu-file wmu_reset wmu-hide' type='file' name='wmu_file[]'/></label><div class='wmu-preview wmu-preview-file wmu-preview-file-1 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-2 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-0_0-file-2' class='wmu-file wmu_reset wmu-hide' type='file' name='wmu_file[]'/></label><div class='wmu-preview wmu-preview-file wmu-preview-file-2 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div></div></div></div>
                                    </div>
                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer" style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name (or Pseudonym)*" maxlength="50" pattern=".{5,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                    </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                        </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper" id='wc-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post" enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img alt='avatar' src='https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2019/07/maxresdefault.jpg' srcset='https://beavercountian.com/wp-content/uploads/2019/07/maxresdefault.jpg 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48'/>                                    </div>
                                
                                <textarea id="wc-textarea-wpdiscuzuniqueid" placeholder="Click here to post your comments to this article!..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                                                    <div class="wpdiscuz-textarea-foot">
                                        <label class='wmu-add wmu-multiple'><span class='wpdiscuz-button wmu-icon-image'>&nbsp;</span><input type='hidden' class='wmu-type wmu-hide' value='image'></label><label class='wmu-add wmu-multiple'><span class='wpdiscuz-button wmu-icon-video'>&nbsp;</span><input type='hidden' class='wmu-type wmu-hide' value='video'></label><label class='wmu-add wmu-multiple'><span class='wpdiscuz-button wmu-icon-file'>&nbsp;</span><input type='hidden' class='wmu-type wmu-hide' value='file'></label>                                        <div class="wpdiscuz-button-actions"><div class="wmu-action-wrap"><div class='wmu-tabs wmu-multi-file wmu-image-tab wmu-hide'><div class='wmu-top-title'>Photo and Image Files</div><label class='wmu-add wmu-add-0 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-image-0' class='wmu-image wmu_reset wmu-hide' type='file' name='wmu_image[]'/></label><div class='wmu-preview wmu-preview-image wmu-preview-image-0 wmu-hide'><div class='wmu-preview-remove'><canvas style='max-height:45px;' id='image-wpdiscuzuniqueid-canvas-0'></canvas><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-1 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-image-1' class='wmu-image wmu_reset wmu-hide' type='file' name='wmu_image[]'/></label><div class='wmu-preview wmu-preview-image wmu-preview-image-1 wmu-hide'><div class='wmu-preview-remove'><canvas style='max-height:45px;' id='image-wpdiscuzuniqueid-canvas-1'></canvas><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-2 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-image-2' class='wmu-image wmu_reset wmu-hide' type='file' name='wmu_image[]'/></label><div class='wmu-preview wmu-preview-image wmu-preview-image-2 wmu-hide'><div class='wmu-preview-remove'><canvas style='max-height:45px;' id='image-wpdiscuzuniqueid-canvas-2'></canvas><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div></div><div class='wmu-tabs wmu-multi-file wmu-video-tab wmu-hide'><div class='wmu-top-title'>Audio and Video Files</div><label class='wmu-add wmu-add-0 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-video-0' class='wmu-video wmu_reset wmu-hide' type='file' name='wmu_video[]'/></label><div class='wmu-preview wmu-preview-video wmu-preview-video-0 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-1 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-video-1' class='wmu-video wmu_reset wmu-hide' type='file' name='wmu_video[]'/></label><div class='wmu-preview wmu-preview-video wmu-preview-video-1 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-2 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-video-2' class='wmu-video wmu_reset wmu-hide' type='file' name='wmu_video[]'/></label><div class='wmu-preview wmu-preview-video wmu-preview-video-2 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div></div><div class='wmu-tabs wmu-multi-file wmu-file-tab wmu-hide'><div class='wmu-top-title'>Other File Types</div><label class='wmu-add wmu-add-0 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-file-0' class='wmu-file wmu_reset wmu-hide' type='file' name='wmu_file[]'/></label><div class='wmu-preview wmu-preview-file wmu-preview-file-0 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-1 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-file-1' class='wmu-file wmu_reset wmu-hide' type='file' name='wmu_file[]'/></label><div class='wmu-preview wmu-preview-file wmu-preview-file-1 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div><label class='wmu-add wmu-add-2 wmu-hide wmu-show'><span class='wmu-add-icon' title='Click to add a file'>&nbsp;</span><input id='wmu-wpdiscuzuniqueid-file-2' class='wmu-file wmu_reset wmu-hide' type='file' name='wmu_file[]'/></label><div class='wmu-preview wmu-preview-file wmu-preview-file-2 wmu-hide'><div class='wmu-preview-remove'><img class='wmu-preview-img wmu-hide' src='data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs='/><div class='wmu-file-name'></div><div class='wmu-delete'>&nbsp;</div></div></div></div></div></div>
                                    </div>
                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer" style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name (or Pseudonym)*" maxlength="50" pattern=".{5,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                    </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                        </div>
                </div>
                                           

                                    <div class="wpdiscuz-front-actions">
                                                    <div class="wpdiscuz-sbs-wrap">
                                <span><i class="far fa-envelope" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fas fa-caret-down" aria-hidden="true"></i></span>
                            </div>
                                                                        <div class="clearfix"></div>
                    </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://beavercountian.com/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType">
                                                                                    <option value="post">Notify of all new follow-up comments</option>
                                                                                                                            <option value="all_comment">Notify of new replies to all my comments</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button"/>
                                </div> 
                                                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="77cee5c24b"/><input type="hidden" name="_wp_http_referer" value="/content/public-meetings/watch-center-township-general-meeting-7-1-2019"/>                                                                <input type="hidden" value="6558888" name="wpdiscuzSubscriptionPostId"/>
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
                                    </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-right-rail-thumbnails"></div>
<script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'taboola-right-rail-thumbnails',placement:'Right Rail Thumbnails',target_type:'mix'});</script>
</div></aside><aside class="td_block_template_1 widget beave-widget"><div style="text-align: center; " id="beave-1942416465"><a href="https://beavercountian.com/membership-account/membership-levels" rel="nofollow"><img width="300" height="600" src='https://d30s8nmy80irhh.cloudfront.net/wp-content/uploads/2018/07/beaver-countian-subscribe-5-300x600.jpg' alt='Subscribe To The Beaver Countian!' style="display: inline-block;"/></a></div></aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Instagram -->




	<!-- Footer -->
	
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap td_stretch_content">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    © 2018 Beaver Countian | <a href="https://beavercountian.com/privacy" target=_blank>Privacy Policy</a>                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->


		<script type="text/javascript" alt='evo_map_styles'>//<![CDATA[
var gmapstyles='default';
//]]></script>		
				<!-- Memberships powered by Paid Memberships Pro v2.0.7.
 -->
		

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.7.3 (rara)
        Deploy mode: deploy
        
        uid: 5d1befc59ab6b
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">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</style>

<script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({article:'auto'});!function(e,f,u,i){if(!document.getElementById(i)){e.async=1;e.src=u;e.id=i;f.parentNode.insertBefore(e,f);}}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/beavercountian-network/loader.js','tb_loader_script');if(window.performance&&typeof window.performance.mark=='function')
{window.performance.mark('tbl_ic');}</script>	<script type="text/javascript">var c=document.body.className;c=c.replace(/woocommerce-no-js/,'woocommerce-js');document.body.className=c;</script>
	<div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id=''>
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
										<div class='evo_lightbox evoau_lightbox ' id='evoau_lightbox'>
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose evoau_lightbox'>X</a>
									<div class='evo_lightbox_body '> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventon-event-slider/assets/evoslider.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventon-event-slider/assets/SL_script.js?ver=1.0.6'></script>
<script type='text/javascript'>//<![CDATA[
var WpwFpPublic={"ajaxurl":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php","emailempty":"Please enter email.","emailinvalid":"Please enter valid email.","loginflag":"0","checkemail":"Please check your email inbox to confirm subscription.","processing":"Processing"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/follow-my-blog-post/includes/js/wpw-fp-public.js?ver=1.9.12'></script>
<script type='text/javascript'>//<![CDATA[
var themeMyLogin={"action":"","errors":[]};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/theme-my-login/assets/scripts/theme-my-login.min.js?ver=7.0.14'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>//<![CDATA[
var wc_add_to_cart_params={"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/beavercountian.com\/cart","is_cart":"","cart_redirect_after_add":"yes"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=3.6.5'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4'></script>
<script type='text/javascript'>//<![CDATA[
var woocommerce_params={"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=3.6.5'></script>
<script type='text/javascript'>//<![CDATA[
var wc_cart_fragments_params={"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_695cfe17ef37a1edaf09a9bb33d1ced9","fragment_name":"wc_fragments_695cfe17ef37a1edaf09a9bb33d1ced9","request_timeout":"5000"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=3.6.5'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/assets/js/essb-core.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=9.7.3'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventON/assets/js/handlebars.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.6.17'></script>
<script type='text/javascript'>//<![CDATA[
var the_ajax_script={"ajaxurl":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php","postnonce":"7e30e58288"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventon-weekly-view/assets/jquery.easing.1.3.js?ver=1'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventon-weekly-view/assets/wv_script.js?ver=1.0.11'></script>
<script type='text/javascript'>//<![CDATA[
var advadsTracking={"ajaxurl":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track","method":"onrequest","blogId":"1"};
//]]></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.8.16'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventon-daily-view/assets/jquery.mousewheel.min.js?ver=1.0.8'></script>
<script type='text/javascript' src='https://beavercountian.com/wp-content/plugins/eventon-daily-view/assets/dv_script.js?ver=1.0.8'></script>
<div id="beave-032b935c344c9ca62a2d248f18142f17"></div><div id="beave-bfd1230b93f3cba807095c105abb70d3"></div><div id="beave-0e91ba0787a746dc91bc1bd5d0eb1679"></div><div id="beave-8e200d8f0491416ba604b2210af9761a"></div><!--noptimize--><script>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</script><!--/noptimize-->
<!-- JS generated by theme -->

<script>jQuery().ready(function(){tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Beaver, US","api_location":"Beaver","api_language":"en","api_key":"75b511454d06ae8d52e655ecf3eac3c2","today_icon":"scattered-clouds-d","today_icon_text":"scattered clouds","today_temp":[31.2,88.2],"today_humidity":46,"today_wind_speed":[4.6,2.9],"today_min":[27.8,82],"today_max":[33.3,92],"today_clouds":40,"current_unit":1,"forecast":[{"timestamp":1562112000,"day_name":"Wed","day_temp":[28,83],"owm_day_index":0},{"timestamp":1562198400,"day_name":"Thu","day_temp":[31,88],"owm_day_index":8},{"timestamp":1562284800,"day_name":"Fri","day_temp":[31,87],"owm_day_index":16},{"timestamp":1562371200,"day_name":"Sat","day_temp":[30,87],"owm_day_index":24},{"timestamp":1562457600,"day_name":"Sun","day_temp":[25,77],"owm_day_index":32}]});});jQuery().ready(function jQuery_ready(){tdAjaxCount.tdGetViewsCountsAjax("post","[6558888]");});</script>

<style type="text/css">.essb_fixed{background:rgba(0,0,0,.75)!important}.essb_fixed{left:0;width:100%;min-width:100%;padding-left:10px}</style><link rel="stylesheet" id="essb-social-followers-counter" href="https://beavercountian.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/social-followers-counter/assets/css/essb-followers-counter.min.css" type="text/css" media="all"/><script type="text/javascript"></script><script type="text/javascript">var advads_tracking_ads={};var advads_tracking_urls={"1":"https:\/\/beavercountian.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track"};var advads_gatracking_uids={"1":""};var advads_tracking_methods={"1":"onrequest"};var advads_tracking_parallel={"1":false};var advads_tracking_linkbases={"1":"https:\/\/beavercountian.com\/linkout\/"};var advads_gatracking_allads={"1":{"6555047":{"title":"Adsense Billboard","target":false},"6551379":{"title":"Kress For Sheriff","target":"https:\/\/www.facebook.com\/kressforsheriff\/"},"6548081":{"title":"Taboola","target":false},"6547840":{"title":"Site Membership","target":false},"6544593":{"title":"Front Page Adsense Skyscraper","target":false},"6544262":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 11","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544261":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 10","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544260":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 9","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544259":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 8","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544258":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 1","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544255":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 7","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544253":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 6","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544251":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 5","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544249":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 4","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544245":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 3","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544246":{"title":"BeaverCountian \u2013 Subscribe Skyscraper 2","target":"https:\/\/beavercountian.com\/membership-account\/membership-levels"},"6544239":{"title":"Adsense Horizontal","target":false},"6543912":{"title":"Adsense Medium Rectangle","target":false}}};var advads_gatracking_anonym=true;</script>
</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->